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Introduction 
 
Welcome to Getting Started with MapLogic Layout Manager.  This book is intended to help you 
get started using the MapLogic Layout Manager extension for ESRI’s ArcMap™, and to 
illustrate the different procedures and methods involved with using the extension. 

What Can You Do With The MapLogic Layout Manager? 
“Create map books” is the simplest way to describe what you do with the MapLogic Layout 
Manager!  Of course it does all kinds of other things which we will talk about later. 
 
Map books are all around us.  Most of us have used a road atlas at one point or another in our 
life.  Many small and large government organizations and private companies create custom 
map books regularly.  Many municipalities need regularly updated street maps for their 
emergency and police vehicles. 
 
In the past, the process of creating a map book was a particularly tedious affair.  Each page of 
a map book had to be created separately.  Creating an index of where things are in the map 
book (for example, Main Street…Page 9) was a very long and difficult process. 
 
The MapLogic Layout Manager automates many of the steps in this process, to the point that 
creating a professional looking map book is not much harder than creating a single sheet map 
in ArcMap. 
 
A map book is, basically, a large map that has been broken down into smaller, more 
manageable sheets.  But it is more than just a collection of small maps.  Each page in a map 
book knows its relationship to the other pages in the book (you’ve seen those little notes on the 
edge of a page that says “continued on page…”).   
 
Map books usually have a key map.  A key map is kind of an overview map of the entire area 
covered by the map book showing what page covers each area of a map. 
 
And, of course, map books usually have indexes.  Indexes list where you can find a feature on 
the map (for example, Main Street…Page 9). 
 
The MapLogic Layout Manager brings all the parts of a map book together in a single product.   
Each part of the book is aware of the other parts.  For example, if you insert map into your map 
pages, all the page numbers are automatically corrected, the map key will automatically update 
itself, the listings in the index will correct themselves to accommodate the new page and so on. 
 
But lets not get ahead of ourselves; we will explain how you do all this further along in the book. 

Tasks You Perform With The MapLogic Layout Manager 
The MapLogic Layout Manager is an extension to ESRI’s ArcMap desktop GIS application.  It 
enhances ArcMap by providing tools to allow you to: 
 

1. Create and store multiple page layouts in a single ArcMap document (Mxd) 
2. Create map series in ArcMap 
3. Create map books in ArcMap 

 
As part of creating a map book, the MapLogic Layout Manager allows you to: 
 

1. Create map series – a map that is broken into multiple pages on different map 
extents 
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2. Create thematic series – a map that is broken into multiple pages based on 
different layer visibilities 

3. Create locator maps – an overview map that highlights the location of the current 
page in a series 

4. Create key maps – an overview map that lists the page number where you can see 
the detailed map of an area 

5. Create indexes – a listing of features on the map and what page they are located 
on 

 
Of course, there are many more details to each of these steps, which we will explore later on. 

Tips On Learning How To Use The MapLogic Layout Manager 
This book is intended to help you learn the basics of making page layouts, map series and map 
books using the MapLogic Layout Manager and ArcMap.  For more detailed information about 
the options and parameters in each of the many tools in this extension, refer to the MapLogic 
Layout Manager User’s Manual as well as the online help. 
 
The MapLogic Layout Manager has 4 different license levels; Viewer, Basic, Advanced and Pro.  
Depending on the license level that you have purchased, you will have different tools and 
capabilities available to you.  At each section in this book, you will see notation which will tell 
you what license you will need to perform the task being described.  The following table will give 
you a quick overview of what you can do at each license level.  Don’t worry if you aren’t sure 
what some of the items listed in the table mean as we will provide plenty of explanation as we 
get further into the book. 
 

License Level: Viewer Basic Advanced Pro 
View different Layouts in ArcMap document 
(Mxd) Yes Yes Yes Yes 

Preview map series and map books Yes Yes Yes Yes 
Print single layouts Yes Yes Yes Yes 
Print maps series and map books No Yes Yes Yes 
Create/edit layouts and map series No Yes Yes Yes 
Create/edit map books No No Yes Yes 
Create location listings in map books (i.e. 
Main street, page 1) No No Yes Yes 

Anchor elements to specific locations on the 
Layout (including two-sided page setups) No No Yes Yes 

Create multi-column location listings in map 
books No No No Yes 

Create multi-layout/multi-layer location listings 
in map books No No No Yes 

Create multi-template sections in map books 
(i.e. Page 9 in a map series uses a different 
template from the rest) 

No No No Yes 

 
The MapLogic Layout Manager is an extension of ArcMap.  We are assuming that you are 
reasonably familiar with ArcMap and have already learned the basics of making maps using 
ArcMap.  So if you aren’t quite comfortable with ArcMap, we would suggest that you spend a 
little time finding your way around ArcMap.  Once you have mastered the process of composing 
and printing a map layout, it’s a good time to get started with the MapLogic Layout Manager. 

Some Basic Terminology 
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If you have been using ArcMap, you are used to some of the basic terminology such as layers, 
maps, layouts, etc.  The MapLogic Layout Manager adds some new objects to ArcMap, which 
we need to become familiar with: 
 
Page Layouts:  A page layout is a single page map.  Up to now, whenever you have been 
putting together a map in ArcMap, you have been working on a page layout.  An ArcMap 
document (Mxd) normally has a single page layout.  With the MapLogic Layout Manager you 
can have multiple page layouts in the ArcMap document. 
 
Map Series Layouts:  A map series layout is a layout that prints over multiple pages.  It looks 
just like a page layout except that you can print or preview multiple maps using the same 
template.   As you go from page to page in a map series, it automatically updates the map by 
moving the visible area of the map, updating page numbers, etc.  This allows you to create a 
single layout for a map series that can be tens, hundreds, or thousands of pages long. 
 
Book Layouts:  Book layouts can contain multiple page layouts, map series layouts, key maps, 
location listings, etc.  A map book is organized into sections, each containing different parts of a 
map book (for example, a cover, a key map, some map pages, a road index, etc.).   
 
Active Layout: Although you can have multiple page layouts, maps series layouts and book 
layouts in your ArcMap document, only one layout can be visible at any time.  The layout that is 
visible is called the active layout. 
 
Map Series Frame, Thematic Series Frame, Locator Frame, and Key Frame:  In ArcMap, 
the basic window that show’s map information in your layout is called a data frame.  With the 
MapLogic Layout Manager, we add 3 new frames to ArcMap.  These frames look just like data 
frames but add more capabilities to the data frame.  For example, a map series frame is a data 
frame that knows how to print over multiple pages.  We will talk more about each frame later. 
 
Series Text:  Series text is just like any other piece of text that you place on your page layout, 
except that it knows how to update itself as you move from page to page in a map series.  A 
good example of a series text is a label showing the page number.    
 
Page Index:  A page index is a tabular listing of where features are on a single map (i.e. Main 
Street, B3).  A page index is placed next to the map. 
 
Series Index:  A series index is a tabular listing of where features are in an entire map series 
(i.e. Main Street, Page 9 B3).  A series index is placed before or after the entire map series. 
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The above sample shows just a few examples of the types of elements you can add to a layout.  
Each element has its own purpose and properties.  Each element knows how to update itself 
based on its properties, which is what makes the extension so powerful. 
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Exploring The MapLogic Layout Manager 
 
Everything you need to get to in order to use the MapLogic Layout Manager extension is in one 
of three locations: 
 
 The “Layouts” tab in the ArcGIS Table of Contents 
 The “MapLogic Layout Manager” toolbar 
 The properties of different layout elements and data frames 

The Layouts Tab 
The Layouts Tab is a new tab that is added to the ArcMap Table of Contents by the MapLogic 
Layout Manager.  If the Layouts tab is not visible after you install the extension, you can make it 
visible by selecting Tools>Options… in ArcMap’s main menu.  Go to the TOC Tab, make sure 
Layouts is checked and press the OK button. 
 

 
 
This tab is where you move around the different layouts contained in the Mxd.  Double-clicking 
on any layout will activate it (make it visible). You can only have one layout active at any time. 
 
Click on any item listed in the Layouts Tab using your right-mouse button and you will see a 
menu of things you can do with that item.   
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This is where you will do most of the work of managing layouts, map series and map books 
(adding/removing new books and layouts, changing the order of sections, etc.).  Different 
commands on these menus are enabled and disabled based on what kind of MapLogic Layout 
Manager license you have (Viewer, Basic, Advanced or Pro). 

The MapLogic Layout Manager Toolbar 
The MapLogic Layout Manager toolbar is a new toolbar that is added to ArcMap by the 
extension.  It is where you will find all of the tools needed to put together a map book.  If the 
toolbar is not visible after you install the extension go to View>Toolbars>MapLogic Layout 
Manager on ArcMap’s Main Menu to display the toolbar. 
 

 
 
You will notice that the toolbar layout is very similar to ArcMap’s Main Menu.  This helps you to 
quickly find the right commands in the extension based on where you would expect to find 
similar commands in ArcMap. 
 
Different commands in the toolbar are enabled and disabled based on: 
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1. What kind of layout is currently active (page layout, map series layout or book 
layout) 

2. What kind of element is currently selected in the layout 
3. What kind of MapLogic Layout Manager license you have (Viewer, Basic, 

Advanced or Pro) 

Element Properties 
When you insert a new MapLogic Layout Manager element (for example a Map Series Frame), 
the element is added to the active page layout just as in ArcMap’s Insert Menu.  To set the 
properties of the element, select it, click the right mouse button and then select “Properties…” 
on the popup menu.  You can also just double-click on the element. 
 

 
 
You will notice that the element will have all the normal properties you would expect for that 
type of element with an added tab for properties specific to our extension.  Modify the element 
properties just like you would with any other element in ArcMap. 
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Working With The MapLogic Layout Manager 
 
In the next chapters we will go through the basic tasks that you can perform using the MapLogic 
Layout Manager.  Here is what we are going to do in the next chapters: 
 

1. Create a index (grid) layer 
2. Learn to work with multiple layouts in an ArcMap document 
3. Create a quick map series and map book using the Book Wizard 
4. Create a map series layout in ArcMap with step by step instructions 
5. Create a new map book layout in ArcMap with step by step instructions 

 
As you will see we are going to start with some pretty simple tasks and gradually build up to 
creating a complete map book. 
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Creating An Index (Grid) Layer For A Map Series 
(Basic, Advanced and Pro) 
 
The most common reason you are interested in using MapLogic Layout Manager is its ability to 
create map series and books.  In other words, the ability to take a large map and split it into a 
number of smaller and more manageable sheets. 
 
MapLogic Layout Manager is able to do this based on an Index Layer.  The index layer is a 
polygon (area) layer in your map where each polygon represents a page in your map series.   
 
Here are some characteristics about an Index Layer: 
 

- It must be a polygon layer. 
- The polygons don’t have to be rectangles.  For example, we used the boundary of 

each state as the Index Layer for an atlas of the United States.  However, 
rectangular indexes often provide the best results. 

- The polygons don’t have to be the same size or the same shape. 
- Not every polygon in the layer has to be a page in the map book.   

 
The MapLogic Layout Manager can use any polygon layer as an Index Layer.  But what if we 
don’t already have an index layer?  The extension provides you with some tools that will create 
grid and linear index layers for you.  If the tools provided by the extension don’t meet your 
requirements, you can always create your own index layer using the layer creation and editing 
tools provided by ArcMap. 
 
Grids can cover an area, follow a line, follow the extent of map features or even entered 
manually.   
  

      
 
Grid an Area   Follow a Line   Map Feature Extents 
 
Before we get into the steps for an index layer, we need to show you another part of the 
MapLogic Layout Manager extension; the MapLogic Layout Manager toolbar.   
 

 
 
If you don’t already have the toolbar visible, you can display it by going to View > Toolbars > 
MapLogic Layout Manager on ArcMap’s Main Menu. 
 
In this chapter we will go through the process of creating a grid that covers an area.  To begin 
with, we are going to make a grid which covers the extent of The United States using one of 
ArcMap’s Templates.  We are going to use a template so we don’t have to spend time setting 
up our layers, colors, labels, etc.  So let’s get started by opening a new ArcMap session using 
the “ConterminousUSA.mxt” template: 
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Once you have the template loaded, your ArcMap session should look something like the 
following: 
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To begin the process, let’s go back to the US map that we have been working with throughout 
this book.  We are going to create a grid over the continental United States similar to the one 
displayed below. 
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Once you have the map open, let’s zoom out so we can see the entire boundary of the 
continental United States.  Select Tools > Grid Wizard… 
 

 
 
This will display the Grid Wizard dialog.  The process of creating an Index Layer using the Grid 
Wizard is to use one or more of the grid tools available on the wizard to populate the Grid List.  
The grid list is essentially a list of rectangles.  
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To begin the process of creating an area grid click the Grid an Area button.  The tool will 
appear at the bottom of the wizard. 
 
In order to create the grid that covers an area software needs to know: 
 

1. The extent of the grid 
2. The size of each grid cell 
3. The order of the grid cells 
4. Rules for limiting grid placement (optional) 
5. Rules for naming grid cells (optional) 

 
The first step in the process is to set the limits of where we would like to create a grid for (the 
grid extent). 
 

 
 
The grid extent can be set selecting the current extent of the map, the full extent of all of the 

data that is on the map or by drawing a rectangle on the map using the Draw Rectangle ( ) 
Tool.  In this example we are going to use the Draw Rectangle tool to set the extent of our grid.  
Just click the Draw Rectangle button and then drag a rectangle across the map to select the 
extent of the grid.  If the Wizard is blocking your view, you can check the Auto-Minimize button 
option which will minimize the dialog while you are interacting with the map. 
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The next step in the process is to set the size of each grid cell.  The size can be set by dividing 
the selected extent to a set number of rows and columns or by selecting specific size in paper 
units or map units. 
 
In this example we are just going to select the number of rows and columns the area is to be 
divided into which is the default option on the tool. 
 

 
 
Since the United States is wider than it is tall, the only change we are making to the default 
values is to change the number of columns to 15 rather than 10. 
 
The next step in the process is to choose the order of the grids.  The order of the grids 
determines the order by which the pages will appear on our map book.  The most common 
order in map books is to go from the upper left to the lower right. This is also the default 
selection on the dialog which we are not going to change. 
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The next step is to set the grid limits.  Since the United States is not a perfect rectangle, there 
are going to be areas on our selected extent that fall outside of the boundary of the United 
States.  We can avoid adding grid cells in these areas by setting the grid limits. 
 
The grid limits instruct the software not to place grids where there is no underlying data in one 
or more layers.  In this case we will be using the States layer to limit the grid 
 

 
 
The final step in the process is deciding how the grid cells are named.  In this example we are 
not concerned with grid names and we will just accept the default values on the dialog. 
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Once you have made all the necessary selections click the Add To Grid List button to complete 
the process.  The wizard will make the necessary calculations and populate the grid list with the 
resulting grids. 
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At this point you can preview the resulting grids or click the Create Grid button to generate a 
shapefile or feature class based on the grid list. 
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Keep in mind that you can edit, delete, merge or split grids in the grid list before saving the 
results. 
 
This completes the process of creating a grid index.  
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Working With Multiple Layouts In ArcMap 
(Basic, Advanced and Pro) 
 
In this section we will introduce you to the concept of multiple layouts in your ArcMap 
document.  We will demonstrate this by performing a very simple task of creating a new layout 
using the MapLogic Layout Manager.  Up to now, whenever you have been using ArcMap, you 
have been working with a single map layout.  With the MapLogic Layout Manager, the ArcMap 
document (Mxd) becomes a multi-layout document.  This allows you to store multiple page 
layouts, map series layouts and map books inside the document.  It is as if there are multiple 
MXDs stored in one.  So the first task we need to become familiar with is how to create these 
new layouts in ArcMap. 
 
To begin this task open ArcMap.  It doesn’t matter if you create a new map or open one that 
you have worked on before. 
 
The very first time you open an ArcMap document after you have installed the MapLogic Layout 
Manager you will notice a new tab added to your Table of Contents, called “Layouts”.  Click on 
the tab so you can see its contents.  You will notice a list showing your Page Layouts, Map 
Series Layouts and Book Layouts.  To begin with the only layout you see in the list is one called 
“Page Layout 1 (Active)”. 
 

 
 
By default you always have one page layout in ArcMap.  When you see “(Active)” in front of the 
name of that layout, it means that it’s the one that is currently visible. 
 
So let’s go ahead and create a new page layout.  In order to do this right-click your mouse on 
where it says “Page Layouts” and select “New Page Layout” from the menu that pops up. 
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You will notice a new item added to the list of Page Layouts called “Page Layout 2”.   And that’s 
how you add a new page layout in your ArcMap document. 
 

 
 

Copying An Existing Layout 
 
What if we don’t want to work on a layout from scratch?  If you want to make a copy of an 
existing layout and modify it, you can Copy/Paste an existing layout.  To do this, right-click on 
the layout you want to copy and select “Copy” from the popup menu.  Then right-click again and 
select “Paste” from the popup menu. 
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Some other things you might want to do once you’ve created a new layout: 

Moving Back And Forth Between Layouts 
Now that we have created the new layout, we need to be able to see it.  We call this “activating 
a layout”.  In order to activate a layout, all you need to do is double-click on its name in the list 
or right click on its name and select “Activate” from the pop-up menu.  You will notice that Page 
Layout 1 will disappear and Page Layout 2 will appear.   The page layout list will also update to 
show which layout is active. 
 

 
 

Renaming Layouts 
Of course, you probably want to name your layouts something that is more descriptive than 
“Page Layout 1”.  To do this, right-click on a layout and select “Rename…”. 

Removing (Deleting) Layouts 
If you would like to remove a layout from your ArcMap document, right-click on the layout you 
would like to delete and select “Remove…” from the popup menu. 
 
Once you have created a new page layout, you can edit and print it just like you have been 
doing so in ArcMap in the past. 
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In the next chapters we are going to create a new type of layout called a Map Series Layouts 
and Book Layouts.  A map series layout is very similar to a page layout, except that it prints out 
a series of map sheets instead of just one sheet.  A book layout is a collection of page layouts 
and book layouts stored as a single document. 

Rearranging Layouts 
You can always rearrange the positions of a layout in the list of page layouts by right-clicking on 
the name of the layout and then going to the “Order” menu. 
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Quickly Creating A Map Series Or Map Book 
(Basic, Advanced and Pro) 
 
Now that we have learned how to create, copy/paste, activate, edit and delete layouts, let’s go 
to the next level and learn how to create a Map Series Layouts and Book Layouts.   
 
In this chapter we are going to create a map series and map book using the Book Wizard. 
Generating a map book or map series using MapLogic Layout Manager is a multi-step process 
with numerous options and settings at each step.  The wizard automates the entire process 
using the most commonly selected options and settings.  In later chapters the same process will 
be repeated using step by step instructions. 
 

Creating A Map Series Using The Book Wizard 
To begin with, we are going to make a map series of US States using one of ArcMap’s 
Templates.  We are going to use a template so we don’t have to spend time setting up our 
layers, colors, labels, etc.  This is also a good example of how easily you can take an existing 
layout and turn it into a map series.  So let’s get started by opening a new ArcMap session 
using the “ConterminousUSA.mxt” template: 
 

 
 
Once you have the template loaded, your ArcMap session should look something like the 
following: 
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You can open the Book Wizard by selecting Tools > Book Wizard… from the MapLogic Layout 
Manager toolbar. 
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In the first example we are going to create a map series of US states.  As was mentioned 
earlier, the wizard makes a number of assumptions when creating a map series or book in 
order to simplify the process.  For example, the wizard assumes that the current map layout will 
be used as a template to create the map series. 
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Since we are creating a map series in this example, select the Map Series option on the Book 
Content tab.  We have also updated the map series name to “US States.” 
 
As we have mentioned before, a map series is driven by a polygon layer in which each polygon 
represents the boundary of a page in the map series.  In our example we would like to have 
each state appear on a page in the series. 
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On the Map Series tab select the “States” layer as the index layer.  Notice that the wizard 
automatically selected the “State_Name” field to sort the pages in the map series.  This makes 
sure that the pages will appear in the map series in order of their names. 
 
This completes all the information needed to create a map series.  Because we are not creating 
a map book, all the selections on the Overview Map, Index Database and Index Layout tabs 
have been disabled. 
 
Note that the last tab in the wizard is a Summery tab.  This tab provides a summary of all what 
the wizard is tasked to do and will let you know if all the necessary selections have been made 
to generate the series.  As the series is being created, the summery tab will update you on the 
wizard’s progress. 
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Press the Create Map Series button to create the series. 
 
Once the wizard has completed its tasks, you can see a new map series layout has been added 
to the Layouts tab in ArcMap’s table of contents.   If you expand the tree you can see the 
individual sheets in the map series. 
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This completes the process of creating a map series using the Book Wizard. 

Creating A Map Book Using The Book Wizard 
In the next example we will be using the Book Wizard to create a complete map book for the 
United States.  While the map series only included the pages for each state, the map book will 
include an overview map and a highway index listing each highway and the pages can be found 
on. 
 
We are going to begin by opening a new ArcMap session using the same 
“ConterminousUSA.mxt” template used in the previous example. 
 
Open the Book Wizard by selecting Tools > Book Wizard… from the MapLogic Layout 
Manager toolbar and go to the Book Content tab. 
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While in the previous example we selected the Map Series option, this time we are going to 
select the Map Book option.  Modify the name of the map book to “US Highway Atlas” and 
change the Map Series name to “States” and the Feature Index name to “Highway Index”. 
 
Click Next to go to the Map Series tab. 
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The selections on the Map Series tab are going to be identical to the previous example. Select 
the “States” layer as the index layer.  The wizard automatically selected the “State_Name” field 
to sort the pages in the map series.   
 
Since we are creating a map book with an overview and index, additional tabs on the book 
wizard are enabled. 
 
Click Next to go to the Overview Tab. 
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On the Overview tab change the Book Title to “US HIGHWAY ATLAS”.  Because we don’t want 
the overview map to be too busy, turn off the Capital Cities, Interstate Highways, Rivers and 
Lakes layers. 
 
Click Next to go to the Index Database tab. 
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To generate an index we need to select the layer that is to be indexed along with the field which 
contains the attribute that will appear in the index.  Indexing is done in two steps.  The first step 
is to generate a database of where the features are located.  Once the database is created, its 
content is added to the map book as a nicely formatted table. 
 
Select “Interstate Highways” as the layer to index and “ROUTE_NUM” as the field to index.  

Click the folder icon ( ) and select a location where the database is to be stored.  In our 
example we are storing the database in “C:\Temp\IndexDatabase.dbf”. 
 
Click Next to go to the Index Layout tab. 
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As was mentioned earlier the indexing is done in two steps, the first creates a database of 
feature locations and the next step lays out the index on paper.  The Book Wizard offers two 
table formats for the index.  In our example we are using the “Boxed” index style. 
 
This completes all the information needed to create a map book.  Keep in mind that there are 
many more options when creating a map book.  The wizard is showing the most common 
options and then making assumptions for the rest. 
 
Press Create Map Book to begin creating the map book. 
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The Summary tab will provide information about the process as it is being completed.  Creating 
a map book is more complex and requires more time to complete.   
 
Once the wizard has completed its tasks, you can see a new map book layout has been added 
to the Layouts tab in ArcMap’s table of contents.  The book contains an overview map, a map 
series of all the states and an index of highways. 
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Overview Map 
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States Map Series 
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Highway Index 
 
This completes our example of using the Book Wizard to create a map series and book.  As can 
be seen, the book wizard greatly simplifies a rather complex process.  
 
In the next chapters we will go through step by step process to create the same map series and 
book.  This will give you a better understanding of where the commands and options are for 
each step in the process.  However, if you take a closer look at the Book Wizard, you will notice 
that we provide information about where you can find the options for each step on the process. 
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Creating A Map Series Layout 
(Basic, Advanced and Pro) 
 
Now that we have learned how to create a map series using the Book Wizard, let’s go through 
the step by step process of creating a Map Series Layout.   
 
A map series is always driven by a polygon layer that we call the Index Layer.  Each polygon in 
the Index Layer represents the boundary of a page in the map series.  In this chapter we are 
going to use an existing polygon shapefile as the Index Layer.  We explained how you can use 
the extension to create new Index Layers earlier in this manual in a chapter called Creating An 
Index Layer For A Map Series. 
 
Now that you know where the toolbar is, let’s get started on making a map series.  To begin 
with, open a new ArcMap session using the same “ConterminousUSA.mxt” template we have 
been using in previous chapters. 
 
Once you have the template loaded, your ArcMap session should look something like the 
following: 
 

 
 
Since we are going to make a map series, we need to Copy/Paste the layout from the page 
layouts area to the map series layouts area.  Just as we showed you in the previous chapter, 
right-click the mouse on the layout’s name and select Copy, then move the mouse down to the 
Map Series Layouts, right-click the mouse and select Paste.  Now that you have a new map 
series layout, double-click on its name in the Table of Contents to activate it.  If you don’t see 
the new Map Series Layout that you have just created, click the little “+” sign next to the Map 
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Series Layouts area on the Table of Contents to expand the tree.   When you are done, your 
ArcMap Session should look something like: 
 

 
  
 
At this point we have created a new Map Series Layout, but the layout is just a single sheet 
layout.  We need to tell the extension how to print this layout over a number of pages. 
 
To complete this task we need to do two things: 
 

1. We need to tell the extension that the map is a map series. 
2. We need to set the parameters of the map series. 

Converting A Data Frame To A Map Series Frame 
To convert the map from a regular map to a map series, we need to select the map frame (data 
frame) and then select Edit > Convert Data Frame to Map Series Frame on the MapLogic 
Layout Manager toolbar.  This option will not be available unless you have the map frame 
selected.  You will see small blue squares on each corner of the frame when it is selected. 
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By converting the data frame to a map series frame, we are telling the extension that this map 
is going to have multiple pages.  However, we still haven’t told the extension where the pages 
are. 
 
Also note that we could create a new map series frame by using the Insert menu on the toolbar. 

Setting Map Series Properties 
To allow a map series to print over multiple pages we need to set the Index Layer for the frame.  
The Index Layer is a polygon (area) layer in your map where each polygon represents a page in 
your map series.  Since we are creating a map series of US States, we want to set the 
boundary of each state to be a page in the series.  The MapLogic Layout Manager will then 
know to zoom to the boundary of each state as it moves from page to page. 
 
How do we tell the extension where the Index Layer is?  When we converted the data frame to 
a map series frame, a new tab was added to the properties of the frame.  To set the Index 
Layer, we need to edit the properties of the frame.  To edit the map series frame’s properties, 
double-click on the frame or right-click on the frame and select “Properties…” 
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You will notice that there is a new tab on the properties window called “Map Series”.  Click over 
to this tab and from the Index Layer drop down list select “United States”.  This is the minimum 
amount of information that the extension needs to make a map series.  However, we don’t want 
just a random set of state maps.  Let’s order the series by state name.  To do this check the 
“Sort the series using this field:” option and then select STATE_NAME from the list of available 
fields.  Once you have done that, click the OK button to exit the dialog. 
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You will notice that the map will change to show the state of Alabama, the first state in our map 
series. 
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We have just created a 51 page map series.  Of course there are plenty of options and settings 
on the map series properties tab that we have not looked at.  There is more information further 
in this book about further modifying the map series in a chapter titled “Creating A Better Looking 
Map Series”.  Here we are just looking at the basics. 

Previewing Pages In A Map Series 
So, we have a 51 page map series, but how can we look at the rest of the pages in the series?  
Well, there are two ways that you can do this.  If you have enabled individual page listings in 
the Layouts Tab (see View > Series and Book Pages in Table of Contents on the MapLogic 
Layout Manager toolbar) a list of pages will be added to the added to the Table of Contents.  
You can go to any page in the map series by double clicking on the page (Basic, Advanced and 
Pro licenses only). 
 
Another method is to display the Preview dialog and flip through the pages using the dialog. 
Select Layout > Preview Pages… from the MapLogic Layout Manager toolbar.  Viewer 
licenses must always use the Preview dialog to look at the pages in a map series. 
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This will popup the preview dialog which will allow you to flip through the pages of the map 
series. 
 

 

Printing A Map Series 
If you would like to print the map series, select Layout > Print… from the MapLogic Layout 
Manager toolbar.  You will be presented with a dialog similar to the ones you see in any word 
processor which will allow you to print the entire series or just a list of pages.   
 
Alternatively, you could select Layout > Export… from the MapLogic Layout Manager toolbar 
to export the maps in all the export formats available in ArcMap. 
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That is the basic process of creating a map series.  Take some time to look at the other 
properties you can set for a map series frame.  You will see that there are a lot of options for 
refining your series to get the results you need. 
 
In the next chapter we will take map series that we just created and convert it into a map book. 
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Creating A Map Book 
(Advanced and Pro) 
 
In the previous chapters we learned how to create page layouts and map series layouts using 
the MapLogic Layout Manager.  In this chapter we will go to the next step in the process which 
is creating a map book.  Notice that an Advanced or Pro license is required to create a map 
book. 
 
How is a map book different from a map series?  Well, as we learned in the last chapter, a map 
series is a layout that prints over multiple pages.  A map book takes a map series and adds to it 
all of the other pieces that make it a book.  Let’s take the example of a road atlas.  A road atlas 
has a series of pages detailing the roads of a selected region.  However, the atlas will have an 
overview map on the front or back cover showing what page the detailed map of an area is.  It 
also usually has an index of road names and what page they are located on.  If you just took 
these map pages and threw away the rest of the atlas, you would be left with a map series. 
 
The MapLogic Layout Manager organizes a map book as a collection of sections.  Each section 
contains one or more layouts defining the contents of that section.  You may want to think of 
sections as chapters in a book. 
 

 
 
The order in which these sections appear in the map book is the order in which they will be 
printed.  Just like a word processing document, the extension will automatically figure out the 
page numbering of the sections based on where they are located in the map book 
 
Now that we have an overview of how map books are stored in ArcMap, lets go get started on 
putting together a map book.  We are going to build on what we have done in the previous 
chapters by creating a map book of US states. 

Setting Up The Structure Of A Map Book 
To begin with, let’s create a new map book.  You do this by right-clicking on Book Layouts in 
the Table of Contents and selecting New Book Layout. 
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Let’s say we want our map book to have three sections; the first containing a key map (an 
overview); the second containing our map pages; and, finally, an index of interstate highways 
and their locations.  To add 3 sections to the map book, right-click on our newly created map 
book and select New Section three times. 
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Just so as not to confuse ourselves, right-click on each section and give it a more appropriate 
name.  While we are at it, we might as well re-name the map book too. 
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At this point we have the general structure of our map book, but the sections are empty.  So we 
need to define the contents of each section. 

Adding A Map Series To A Map Book 
Normally, you would create a new layout and setup its map properties to add a new map series 
to a book.  However, the steps are the same setting a map series layout.  So let’s make use of 
the work we did in the previous chapters by copying our US States map series and pasting it 
into the State Maps section.  As before, right-click on the layout we want to copy and select 
Copy from the popup menu, then right-click on the appropriate section and select Paste. 
 
Since we have already setup the map series properties of the layout, we don’t need to do 
anything more to the template for this section. 
 
Also note that the map series that we have copied into the book is totally independent of the 
map series that is in the map series layouts section. Even though the two look identical, they 
are unrelated at this point.  We could go back and delete the map series old map series and it 
would have no effect on the one that is now in our map book. 

Adding A Key (Overview) Map To A Map Book 
Now let’s work on creating an overview map.  If you remember, back at the beginning of this 
whole process we started with a page layout which had a map of the conterminous United 
States.  In order to simplify our work, let’s go back to that layout and copy it to our Overview 
Map section.  Once you have copied the layout into the Overview Map section, activate it so we 
can modify its settings. 
 
At this point, your ArcMap section should look something like this:  
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Now that we have a layout for our overview (key) map, let’s go ahead and setup its properties 
so it will display the page numbers in our map book. 
 
To complete this task we need to do two things: 
 

1. We need to tell the extension that the map is a key map. 
2. We need to set the parameters of the key. 

 
To convert the map from a regular map to a map series, we need to select the map frame (data 
frame) and then select Edit > Convert Data Frame to Series Key Frame on the MapLogic 
Layout Manager toolbar. 
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By converting the data frame to a series key frame, we are telling the extension that this map is 
going to show on what page a detailed map of each state can be found.  However, we still 
haven’t told the extension what map series this key map belongs to. 
 
How do we tell the extension what map series this key belongs to?  When we converted the 
data frame to a series key frame, a new tab was added to the properties of the frame.  We need 
to edit the properties of the key frame and link it to our map series of state maps.  To edit the 
series key frame’s properties, double-click on the frame or right-click on the frame and select 
“Properties…”.   
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Once the properties dialog is visible, click on the Series Key tab to modify the properties of the 
key map.  Select the appropriate Section, Layout and Map Series to link the key map to and 
click OK. 
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After clicking OK, you will notice that labels have been added to the map depicting the page 
location of each state.  You might need to zoom in on the map to see this better. 
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At this point, we have created an overview or key map for our map book.  However, the map 
needs some clean up to give it a more professional look.  Some of the unnecessary layers and 
labels should be removed.  The key label text and font might be modified.  We will leave these 
changes for you to explore.  For example, after we cleaned up the map we ended up with a 
map that looks like this: 
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Now that we have our map series and key map, we will next explore the process of creating an 
index of US highways. 

Creating A Highway Index 
The last step in our example map book is to create an index of US highways.  This is a two step 
process.  First we need to create a database of highways and the pages they appear on.  We 
call this an Index Database.  The second step is to take that database and put its contents in a 
layout for printing. 

Creating An Index Database 
To begin the process we need to activate the section in our map book containing the map 
series we are going to index.  Once the layout is active select Tools > Indexing Wizard… from 
the MapLogic Layout Manager toolbar.   
 

 
 
 
This will bring up the Indexing Wizard dialog.  In this dialog we are going to setup the process 
for creating the database.   
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The Indexing Wizard is capable of generating an index database from multiple layouts and 
multiple layers in your map book.  In our example we will be generating the index from a single 
layer. 
 
We need to define the following parameters: 
 

1. The map(s) to be indexed 
2. The layer(s) to index 
3. The boundary (or boundaries) to compare the layer too 
4. The attributes to extract from the selected layer 
5. A file name where the results should be stored. 
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The Map(s) tab in the Indexing Wizard allows you to select which maps in the map book will be 
included in the index.  If your map book had multiple sections (for example a regional maps 
section and a local maps section), you could generate the index from all sections.  In our 
example the only other section in our map book is the overview map which we do not need to 
index. 
 
By default the current map is selected for indexing.  We do not need to make any changes on 
this tab. 
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The Layer(s) tab allows you to select which layers should be included in the indexing process.  
The wizard is able to index across multiple layers (for example, city roads and county roads). 
 
In this example we will be indexing the Interstate Highways layer so you need to check this 
layer.  This is the only change that needs to be made on this tab. 
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Now that the maps and layers to index have been selected, the next step is to select the 
indexing boundaries.  The indexing boundaries refer to what the selected layer’s features will be 
compared against to decide whether the feature is inside or outside the boundary.  Most 
commonly the boundary of the map page is used for this comparison, but the wizard can also 
use any polygon layer for indexing. 
 
In our example we will be comparing the Interstate Highway layer against the boundary of each 
page in the map series and generate a table of which pages each highway appears on.  This is 
the default option on the Indexing Boundaries tab and no changes need to be made on this tab. 
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Now that we have decided what to index, we need to let the wizard know what information is to 
be extracted from the selected layer and placed in the index database. 
 
In our example we are generating a database of the highway route number and the page(s) it 
appears on.  Therefore, we need to define two columns for our index database. 
 
The first column will have our highway route number.  To add a column to the database, press 
the Add button. 
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A new window will appear in which you can define the column name and the column source.  
This first column will contain the highway route number.  In our example we are naming the 
column “Listing”.   
 
Note that, by default the wizard assumes that this column will be populated using the layer that 
is being indexed.  We will not change this option. 
 
Press OK to add the new column. 
 
You will notice a column named “Listing” has been added to the Output Columns tab.  
 
Now we need to add a second column for the page number. To add a column to the database, 
press the Add button. 
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The second column will contain the page number for each feature.  We will call this column 
“Page”.   
 
For this second column we want to change its source so that it will be populated with the page 
boundary information.  Select the This column will be populated with the book or series 
page number option.  
 
Press OK to add the new column. 
 
You will notice that if you click on each column name in the Output Columns tab the wizard has 
added a default expression for each column.  The expression lets the wizard know what 
information is to be placed in the selected column.  An expression can be a simple field attribute 
name or a complex statement based on multiple fields and other formatting. 
 
In our example, the default expressions are correct. 
 
However, in some cases you may need to edit the default expression.  You can do this by 
selecting the column you want to edit and then pressing the Expression button.  This will display 
the MapLogic Expression Builder dialog.  For more information about this dialog and 
expressions, please refer to the User Manual. 
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The next tab on the wizard is the Sort Order tab.  This tab allows you to sort the resulting 
database. 
 
In our example the default sort settings are correct in that the database will be sorted on the 
route names first and the page numbers second. 
 
The only change that need to be made on this tab is to select the Correctly sort numeric text 
option.  This option insures that numeric text is sorted correctly.  Since are interstate names are 
numeric, this option should be applied. 
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The final step in the process is to select a destination file location for the resulting database. 

Click the folder icon ( ) and select a location where the database is to be stored.  In our 
example we are storing the database in “C:\Temp\IndexDatabase.dbf”. 
 
Now that all the necessary options have been selected, press the Finish button to generate the 
index database.  The Wizard will compare the Interstate Highway layer against the 51 US State 
map pages and generate a database of where everything is located.  Once the process has 
ended, you will see a table of listings and their page locations. 
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Note that there were a number of different options on each tab of the Indexing Wizard dialog 
that we did not go over.  Most of the options include explanations on the wizard but you can 
also refer to the User Manual for additional information. 
 
Also notice that there are Save and Load buttons on the Indexing Wizard dialog.  These buttons 
allow you to store the dialog settings in an external file which can be loaded at a later date.  
Most organizations will renew their map books on a regular basis to reflect changes that have 
occurred over time.  The index database is a snapshot of feature locations at the time it the 
database was generated and does not automatically get updated as the layers are updated.  
Therefore the database must be regenerated each time the map book is updated.  The ability to 
save the wizard settings simplifies this process since you don’t need to remember the settings 
from the previous indexing. 
 
Now that we have our database, we can go to the next step which is including it as part of our 
map book. 

Creating A Series Index Frame 
To start the process, let’s go to the Highway Index section of our map book. Right-click the 
mouse and select New Template.  Once the template has been created, go ahead and activate 
the template.   
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Now that we have created our empty layout, we need to add a Series Index to the layout so that 
we can display the contents of our listing database.  Select Insert > Series Index from the 
MapLogic Layout Manager toolbar. 
 

 
 
Once the index has been added to the layout, go ahead and resize it to cover most of the page.   
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You have probably noticed that ArcMap adds a data frame to every layout.  Even though we 
aren’t going to be using this data frame, there is no way to delete it.  If you delete the frame, 
ArcMap will create another.  However, don’t worry, as long as we leave the data frame empty, it 
won’t be displayed at print time.  If you would prefer, you can drag the data frame off to the side 
so that it doesn’t get in the way when you are setting up your Series Index. 
 
Now that we have resized the Series Index, let’s modify its properties.  To do this, double-click 
on the frame, or right click and select Properties…  After the properties dialog is displayed, click 
on the Series Index tab to modify the properties of the index. 
 
The first thing we need to do is to tell the index where the Location Listing Database is located.  
Click on the folder icon and select the database file we created in the previous step.  Once a file 
is selected, the dialog examines the contents of the database to make sure it is valid and also 
populates most of the parameters in the dialog based on what it finds. 
 
Once we have selected the database file, the next step is to link the index to its parent map 
series.  Although linking the database to the map series isn’t required, by linking the two, the 
extension will correct the page numbers to reflect the position of the map series in the map 
book. 
 
For example, suppose Main Street is located on the first page in a map series.  In the Location 
Listing Database Main Street will be listed as being on page 1.  However, suppose that the map 
series doesn’t start on the first page of the map book.  In our example, we have a key map on 
page 1 of our map book, so the map series actually begins on page 2 of the book.  By linking 
the index to the map series, the extension will realize this and correct the listing so that Main 
Street is listed as being on page 2 of the book. 
 
To link the Series Index to the Map Series Frame, check the Link Database to Map Series 
Frame option and then select the appropriate, Section, Template and Map Series Frame from 
the drop-down lists. 
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Next, we need to modify the index layout.  The index is displayed as a series of columns 
containing the listings and their corresponding page numbers.  For each column, you can define 
the column width, the font, the background color and many other parameters.  In our case we 
are only going to modify one item and accept the default values for all the other settings. 
 
To modify the index layout, click on the Index Layout tab. 
 
The only property we are going to modify on this tab is that we are going to set the page 
number so that it is corrected for the location of the map series frame.  In order to do this, click 
on Page in the list of columns and then set the Get Text from Map Series Frame’s Index Layer 
Table option. 
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This is the only modification we are going to make to the Index Layout.  However, you may wish 
to explore the different tabs for the column properties to see all the changes you can make to 
the column. 
 
The next tab is the Display/Sort Order tab.  This is where you determine how the listings will be 
sorted and the order in which the columns appear in the index.  We are not going to make any 
changes to this area. 
 
The final tab is the Options tab.  Since we know each highway is going to appear on many 
pages in our map book, we are going to make combine the listings to save some space in the 
index.    Make sure the “Combine multiple listings of the same feature” option is checked and 
then select “Separate listing pages using:”.  By default, the page numbers are separated with a 
comma (“,”) which is what we will use. 
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These are the only modifications we are going to make to the Series Index.   
 
Click OK to accept the settings.  At this point, the extension is figuring out the appropriate text 
for each listing in the index, removing duplicate listings, sorting the listings, and then laying out 
each page of the index.  The extension also determines how many pages will be required to 
print the index.  Note the progress of the process on the ArcMap Status Bar.  Once the process 
is complete, you will see your index in the layout. 
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Just as a map series, you can preview the rest of the pages in the index by selecting Layout > 
Preview Pages… from the MapLogic Layout Manager toolbar.  To print the map book, select 
Layout > Print… from the toolbar. 
 
This completes our map book creation example.  To review our work, we first created a new 
map book and added 3 sections to our book.  We copied a map series to one of the sections in 
our map book.  We then created a key map in another section which showed the location of 
each page in the book.  Finally, we created a database of highway locations and added it to the 
last section in our map book. 
 
There are many options for each step of this process that we didn’t cover.  For more information 
about these options, refer to the MapLogic Layout Manager User’s Manual. 
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Creating A Better Looking Map Series 
(Basic, Advanced and Pro) 
 
In the previous chapters we created a quick map series using the US state boundary.  
However, we spent little time on the details of each page in the series.  In this chapter we are 
going to explore some of the tools provided by the MapLogic Layout Manager that allow you to 
further customize the map series.  In particular, we are going to learn how to: 
 

1. Add adjacent page labels to each map in the series 
2. Add page numbers to the map series 
3. Add a locator map to the map series 

   

Adding Adjacent Page Numbers To A Map Series 
Adjacent page numbers are labels on the edge of the map that tell users what page to go to if 
the map feature they are looking for goes beyond the current page in the map series.  The 
MapLogic Layout Manager automatically adds these labels to a map series.  In fact if you look 
closely to the map series that we created earlier, you will notice the labels on the edge of the 
map. 
 

 
 
Now let’s take a closer look at the options available to us when creating these labels.  The 
properties of the adjacent page labels are part of the properties of the map series frame.  As we 
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learned in previous chapters, we edit the properties by double clicking on the Map Series 
Frame or right-clicking and selecting Properties… 
 
Once you have the properties dialog visible, select the Map Series tab.  You will notice that the 
Map Series tab has three sub-tabs.  Click on the Adjacent Page Label tab so that we can see 
its contents. 
 

 
 
As you can see, we have a number of choices when placing adjacent page labels.  The first 
option is the text for the label.  As we have seen before, the text of a label is determined by an 
expression.  The MapLogic Layout Manager translates this expression into an appropriate label. 
 
By default, the adjacent page label expression is “See Page $$ADJACENT_PAGE_NUMBER” .  
Anytime you see something in an expression that starts with $$, you are looking at a reserved 
word.  This is a word that the extension understands and substitutes for an appropriate value.  
For example, in our case, the actual label might look like “See Page 3”.   
 
Why use an expression?  Well, this allows you to have total control over what the label says.  
Suppose you prefer the label to say “Go To 3”.  All you would need to do is to change the 
expression to say “Go To $$ADJACENT_PAGE_NUMBER”. 
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Now, let’s suppose that for our US State map series we would like the label to say something 
like “See Mississippi (Page 25)”.  In this case, we need to create an expression that not only 
has the page number, but also the state name.  In order to create this expression we need to 
extract information from our index layer which has the boundaries of each state. 
 
In our case the expression that we need will look like: 
See [STATE_NAME] (Page $$ADJACENT_PAGE_NUMBER) 
 
Anytime we use brackets “[ ]” around a word, the extension interprets this as being the name of 
a field in the table.  So, in this case we, are telling the extension to look in the STATE_NAME 
field in the index layer’s table. 
 
We are going to leave further explanation on building expressions to the User’s Manual.  
Fortunately, the extension provides you with an expression builder that makes building 
expressions much easier.  To display the expression builder click the Expression button. 
 

 
 
The expression builder presents you with a list of reserved words and database fields that you 
can drop down into the expression by selecting each item and clicking the Add button.  Once 
you are done composing the expression, click the OK button to accept the expression. 
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We can also change the text symbol used for the adjacent labels.  To change the label symbol, 
click the Symbol button and select the symbol.  In our example, we have selected a red 
bold/italic label. 
 

 
 
There are also some options about the distance of the label from the map as well as the label 
angle.  We aren’t going to make any changes to these options.  Click OK to apply the label 
properties. 
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As you can see, the adjacent labels have changed to reflect the new settings. 

Adding Page Numbers To A Map Series 
In this section we will learn how to add a page number label to our map series or map book.  
We accomplish this by adding a Series Text Element to our map.  A Series Text element is a 
text label that changes from page to page. 
 
To begin the process, let’s add the Series Text element to our map series.  Select Insert > 
Series Text from the MapLogic Layout Manager toolbar. 
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You will notice a new text label appearing in the center of the layout with the label “Page 1”.  
Let’s grab the label and move it next to the map title.   
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Double click on the label to display its properties.  As you can see, there is a new tab on the 
text label properties called Series Text.  Click on this tab. 
 

 
 
Notice once again that we are using an expression to determine the contents of the text label.  
The default expression for the label is “Page $$PAGE_NUMBER”, which will display the page 
number of the current page in the series. 
 
For our example, let’s say that we would also like to display the name of the state along with the 
page number.  In order to accomplish this, we must first set the series text to get its text from 
the map series.  Click the Get text from Map Series Frame option and then select the North 
America map series.  Now click the Expression button and modify the expression to say: 
 
[STATE_NAME] 
Page $$PAGE_NUMBER 
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You may also want to modify the label font so that it’s a little more prominent on the map layout.  
Note that we have split the expression over two lines so our label will also be made of two lines.   
Click OK to apply your changes.   
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As you can see, we now have a label on our map showing the page number and state name.  If 
you click Layout > Preview Pages… on the MapLogic Layout Manager toolbar, you will notice 
that this label changes as you move from page to page in your series. 

Adding A Locator Map To A Map Series 
 
The last element we are going to add to our map series is a locator map.  A locator map is a 
small map that highlights the location of the current page with respect to the rest of the pages in 
a map series. 
 

 
 
To begin the process of creating a locator frame we are going to Copy/Paste the large map on 
the layout and then reduce its size and place it on the maps title area.  We could also create the 
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map from scratch, however, this way we don’t have to spend time setting up our map layers 
and symbols. 
 

 
 
As you can see, the map is currently much to busy for this size.  Let’s turn off all the layers 
other than the state boundaries, remove any labels that are on the map and also zoom out to 
the extent of the continental US. 
 
You should end up with a small map that looks more or less like this: 
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Now that we have cleaned up the map, make sure the map frame is selected and then click on 
Edit > Convert Data Frame to Series Locator Frame on the MapLogic Layout Manager 
toolbar.  You will get a warning about converting.  Click Yes to making the change. 
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Now that we have converted the data frame into a series locator frame, we need to set the 
properties of the locator map.  This basically involves telling the locator where the map series 
frame is, and also setting the symbol it will use to highlight the current page. 
 
To edit the locator frame properties double click on the locator map or right-click and select 
properties.   
 
Once the properties dialog is visible, click on the Series Locator tab.  Now select the North 
America map series from the Map Series Frame List. 
 

 
 
You may also want to click on the Current Page Symbol tab and modify the symbol used to 
highlight the current page.   
 
Once you are done with your changes, click OK to apply the properties.  Your locator map 
should now be highlighting the first page in the map series. 
 

Getting Started with MapLogic Layout Manager   Page 85 



 

 
 
As you preview your map series, you will see the highlighted area on the map change as you 
move from page to page. 
 
This completes our chapter on creating a better looking map series.  As you can see, the 
MapLogic Layout Manager provides you with many powerful and flexible tools to create 
professional looking map books in ArcMap. 
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Where To Go From Here 
This completes our Getting Started manual.  At this point, you should have a good 
understanding of how to create basic layouts, maps series and map books.  Of course, the 
process of creating a quality product that is ready for publication requires much more work. 
 
Remember that we have only given you a brief overview of how to use MapLogic Layout 
Manager.  There are many more features and tool in the extension compared to what we have 
covered in this manual. 
 
For further information about the MapLogic Layout Manager’s tools and properties, refer to the 
User’s Manual and the online help. 
 
If there is one suggestion that we could make about creating map series and map books, it 
would be to plan your design.  You should remember that every modification you make can 
change tens, hundreds or thousands of pages, so take your time and plan things thoroughly. 
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Receiving Technical Support  
 
Before you contact MapLogic Support, please make sure you have the product name and serial 
number ready.  
 
Online Support Documents  
 
Our online support documents have the answer to many of your questions. Check out our 
online help at the following address: 
 
http://www.maplogic.com/support/support.html 
 
If you can't find what the answer to your question online, you can always contact MapLogic's 
support staff by e-mail or phone. 
 
E-Mail Support (support@maplogic.com)  
 
To contact MapLogic support by e-mail, send your support requests to support@maplogic.com 
or use our online support form at the above Internet address. Please make sure to include a 
daytime phone number in case we need to call you. 
 
E-mail support is available to users 24 hours per day (requests for support received after 4:00 
PM Eastern Standard Time are handled the next business day.) You must provide your 
customer or product serial number and be eligible to receive support in order for us to process 
your request.  
 
Telephone Support  
 
To contact MapLogic support by phone, call (407) 657-1250 7:00 AM to 4:00 PM Eastern 
Standard Time Monday through Friday. Please make sure you have the product name and 
serial number ready to give to the operator.   
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Contacting MapLogic Corporation 
 
Contacting MapLogic Corporation  
 
Mailing Address:  
 
MapLogic Corporation 
330 West Canton Ave. 
Winter Park, FL  32789  USA 
TEL: 407-657-1250 
FAX: 407-657-7008 
 
Internet: www.maplogic.com 
 
Marketing & Product Sales  
 
To contact the MapLogic Marketing Department, e-mail us at marketing@maplogic.com or call 
us at (407) 657-1250 7:00 AM to 4:00 PM Eastern Standard Time Monday through Friday. 
Please make sure to include a daytime phone number in case we need to call you. 
 
Technical Support  
 
To contact MapLogic support by e-mail, send your support request to support@maplogic.com 
or use our online support form. Please make sure to include a daytime phone number in case 
we need to call you. 
 
To contact MapLogic support by phone, call (407) 657-1250 7:00 AM to 4:00 PM Eastern 
Standard Time Monday through Friday. Please make sure you have the product name and 
serial number ready to give to the operator. 
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